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   شعبان1388مرداد 



  پیشگفتار
 این اولین قسمت از آموزش موتور قدرتمنـد و جدیـد  !! سلام به همه ي دوستداران بازي سازیه ایرانی   . سلام

Unity           هست که تو اینترنت به زبان فارسی پیدا می شه و اولین آموزشیه که باید قبل از شروع کار بخونید  .
. این آموزش محیط کار این موتور رو شرح می ده و شما رو به صورت کلی با محیط این موتور آشنا می کنه     

موزش ساخت بازیه اول شـخص  بعد آشنا شدن باید آموزش اسکریپت نویسی رو بخونید تا بعدش بتونید آ       
مطمئن باشید بـا ایـن موتـور هـر بـازي اي کـه بخواهیـد بـدون         . و پلتفرمر دو بعدي و سه بعدي رو بخونید        

 درصـد زمـان سـاخت بـازي     80در صد کدنویسی کل زمـان سـاخت، بـسازید یعنـی     20دردسر و با کمتر از   
 دیگه اي نه من و نه هـیچ کـس دیگـه اي     می شه به طراحی بازي و این یعنی عالی که تو هیچ موتور              طمربو
امیدوارم بهترین بازي ها رو از شما عزیزان ببینم و روزي برسه که وقتی بـه بچـه هـامون بـازي مـی                  !! دیده

پـس تـلاش کنیـد تـا     . خریم بگیم که این بازي رو با همت ما بزرگ هاي ساخت بازي در ایران ساخته شده        
 تـاریخ بـازي    دراین بهترین فرصت براي ثبت نـام شـما  . ان باشید شما یکی از این بزرگهاي بازي سازي ایر       

  !!پس غافل نمونید. هاي ایرانی هست
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  هدف هاي آموزش.1

 هستید، این آموزش اولین آموزشی است که در مورد آن مـی   Unityاگر شما کاربر تازه کار      
 و همچنـین  Unityاین آموزش شرح دهنده ي قسمت هـاي کلیـدي واسـط کـاربري         . خوانید

  . ي بازي و قرار دادن آن در فضاي سه بعدي می باشدساختن اشیاء ساده
، ما صحنه ي ساده اي خواهیم ساخت کـه در  Unityبراي نشان دادن پایه هاي واسط کاربري    

  .آن شخصیت بازي بتواند بر روي سطحی صاف حرکت کند
  . شروع می شود"-"هر خطی که نیاز به انجام کاري توسط شما داشته باشد، با حرف : نکته

  
  
  چیدمان صحنه. 2

 قـرار  Split 2کنیم، بیایید مطمئن شویم که چیدمان صحنه ي ما در حالت  قبل از اینکه شروع
  .دارد

 را از منـوي اصـلی   Window>Layouts>2 Split بـراي اینکـه مطمـئن شـوید، گزینـه ي      -
  .انتخاب کنید

 : قسمت تقسیم شده است5حال نماي دید شما به 

1 .Scene View : دادن اشیاء در صحنهبراي قرار.  
2 .Game View :این چگونگی نماي بازي شما را هنگامی که اجرا می شود نشان می دهد.  
3 .Hierarchy View :       این لیست تمام اشیاي بـازي اي کـه در صـحنه ي فعلـی شـما وجـود

  .دارد را نشان می دهد
4 .Project View : این لیست تمام محتواهایی )Asset ( تفاده کرد را نـشان  که می توان اس

  .می دهد



5 .Inspector View :که انتخاب شده است این نشان دهنده ي خواص شی اي است.  
  
  
  پیدا کردن اشیاء بازي در فضاي سه بعدي. 3
- Unityخب با ایجاد پروژه اي جدید شروع می کنیم. را اجرا کنید.  
ه پـروژه ي خـود اسـمی     را انتخاب کرده و ب ـFile>New Projectاز منوي اصلی گزینه ي -

حـال  .  کلیک کنیـد Create Project بدهید و سپس بر روي دکمه ي "GUI Tutorial"مثل 
Unity  محتویاتی  )Asset ( که در خود دارد )   را بـه  ) مانند صداها، تکـسچرها، مـدلها و غیـره

کامـل شـد، شـما بـا        ) Import(بعد از اینکه عملیـات وارد کـردن         .پروژه ي شما وارد می کند     
  .بازي خود ملاقات می کنید) World(دنیاي 

) به صـورت پـیش فـرض   (  می باشدMain Cameraدنیایی که می بینید فقط داراي یک شی 
  . خود می بینیدHierarchy Viewکه شما فقط نام این شی را در لیست 

ــین را در   - ــد دورب ــی توانی ــر نم ــر روي  Scene View اگ ــد، ب  در Main Camera ببینی
Hierarchy Viewسپس نشانگر ماوس را روي .  کلیک کنیدScene View  برده و کلیـد F 

  .را فشار دهید
از این تکنیک بـراي پیـدا   .  باشدScene View در مرکز دید Main Camera شی حال باید

  .کردن هر شی اي در صحنه می توان استفاده کرد
ر روي اسـم آن در  هر شی اي را می توان با کلیک کردن بر روي آن و یـا کلیـک کـردن ب ـ               -

Hierarchy Viewاگر شما بـر روي شـی اي در   .  انتخاب کردScene View   ،کلیـک کنیـد 
 نام آن شی به رنـگ روشـن در مـی آیـد تـا مطمـئن شـوید کـه شـی          Hierarchy Viewدر 

  .انتخابی درست انتخاب شده است یا خیر
  
  
  بازيء ساختن اشیا. 4

  .ه کنیمبیایید مقداري شی بازي به دنیاي خود اضاف
 شـی  ارایـن ک ـ .  را انتخاب کنیـد Object>Create Other>Plane از منوي اصلی گزینه ي -

Plane     که اجازه می دهد شخصیت ما بـر روي آن  ). یک سطح دو بعدي  .(  اي را ایجاد می کند
  .حرکت کند



 را انتخاب کنید تـا یـک مکعـب    Object>Create Other>Cube از منوي اصلی گزینه ي -
  .بازي اضافه شودبه دنیاي 

 را انتخاب کنیـد تـا یـک    Object>Create Other>Point Light از منوي اصلی گزینه ي -
  .نور نقطه اي به صحنه اضافه شود

  
  
   )Scene View( هدایت کردن نماي صحنه . 5

  :شما می توانید با استفاده از قابلیت هاي زیر به دورتا دور شی سه بعدي خود نگاه کنید
  چرخش.1
  وم کردنز.2

براي چرخش کلیک رایت ماوس را نگه داشـته و بـا تکـان دادن آن و همچنـین دکمـه هـاي              
W.S.A.Dدر صحنه چرخش و گشت و گذار کنید .  

  .براي زوم کردن با چرخاندن قرقره ي میانی ماوس به جلو و عقب این کار را انجام دهید
  .این دستو رات را تمرین کنید-
  
  
  حرکت دادن اشیاء بازي. 6

  :شما می توانید شی سه بعدي خود را با استفاده از قابلیت هاي زیر در صحنه حرکت دهید
سـه  .  را بزنیدWشی مورد نظر را در صحنه انتخاب کنید و کلید         ). Wکلید  ( ابزار حرکت    .1

جهـت سـبز   .  اسـت Xجهت قرمـز رنـگ محـور        . جهت در داخل شی انتخابی نمایان می شود       
  . استZرنگ محور  و جهت آبی Yرنگ محور 

براي حرکت دادن هر شی بر روي هر جهتی که می خواهید کلیک چپ ماوس را بر روي آن               
دقت کنیـد کـه مختـصات مکـان آن شـی در پنـل              . جهت نگه داشته و ماوس را حرکت دهید       

Inspector View ) شـما مـی توانیـد بـه صـورت دسـتی      . نیز تغییر می کند) درسمت راست 
همچنین شما می توانید مکان شی مـورد نظـر را بـه    . را از آنجا بدهیدمختصات شی مورد نظر    

که می خواهید برده و در حـالی          کار دوربین را به هرکجا     ینبراي ا . مکان دوربین منتقل کنید   
 Object>Align Withکه شی مـورد نظـر انتخـاب شـده اسـت، از منـوي اصـلی گزینـه ي         

Viewه مکان دوربین شما منتقل می شودخواهید دید که شی انتخابی ب. را بزنید.  



  
  
 در کیبـورد، ابـزار   Eبا انتخاب کردن هر شی و سپس زدن کلید       ). Eکلید  ( ابزار چرخش   . 2

براي چـرخش شـی بـه دور هـر محـور، بـر روي آن محـور        . چرخش آن شی نمایان می شود     
بی را همـانطور کـه شـما شـی انتخـا       . کلیک چپ ماوس را نگه داشته و ماوس را حرکت دهید          

 مقـدار چـرخش آن شـی    Inspector Viewچرخش می دهید، دقت داشته باشید که در پنل 
  .همچنین می توان این مقدار را به صورت دستی تغییر داد. نیز تغییر می کند

  

  



مکعب ساخته شده را حرکت دهید تا از صـحنه  .  حال بیایید یک تمرین کوچک انجام دهیم       -
حـال آن را مقـداري   . ه به فضاي دید شما بـازگردد ر را بزنید تا دوبا   Fسپس کلید   . خارج شود 

  . برسدPlaneحرکت دهید تا به نزدیکی شی 
  .ساخته شده را به بالاي مکعب منتقل کنید ) Point Light(  حال نور نقطه اي -
  
  
   )Game View( نماي بازي . 7

بـه  ( کـه اجـرا شـده اسـت    نشان دهنده ي بازي در هنگامی است ) Game View(نماي بازي 
اگر شما محیط بـازي خـود را در نمـاي بـازي نمـی             ...). صورت کامل با تکسچر ها و نور ها و          

جهـت   یعنـی . بینید، به این دلیل است که دوربین شما به نماي مناسبی از بازي نگاه نمی کنـد                 
  .آن را باید به نماي دلخواه تغییر دهید

ال شما اهرامی را که بـه صـورت سـیمی    ح.  کلیک کنیدMain Cameraبر روي شی  -
( ایـن اهـرام بـه عنـوان فـضاي دیـد        . رندر می شـود را در جلـوي دوربـین مـی بینیـد             

Viewport (    دوربین شناخته می شود ).           چیزي که توسـط دوربـین دیـده مـی شـود .(
اگر فضاي دید دوربین بر روي شی مورد نظر شما در صحنه نیست، بـا حرکـت دادن              

حـال مـی توانیـد در نمـاي     . ا به طرف شی مورد نظر قـرار دهیـد    یا چرخش آن، آن ر    
  . شده ببینیدربازي شی مورد نظر را به صورت رند

در ضمن شما می توانید دوربین خود را حرکت داده یا بچرخانید تا به مکـان دلخـواه                -
 . نیز به صورت دستی قابل انجام استInspectorاین کار در پنل . ببرید

مکان نور نقطه اي ایجـاد کـرده را در صـحنه تغییـر دهیـد تـا بـه               همچنین می توانید     -
 .صورت دلخواه شما در آید

  
  
  تغییر اندازه ي اشیاء بازي. 8

.  را بزنیدRبراي تغییر دادن اندازه ي اشیاء بازي ابتدا آن شی را انتخاب کرده و سپس کلید              
 هر محور، شی انتخابی را مربع هاي موجود در انتهاي    شما می توانید با گرفتن و حرکت دادن         

 نیـز بـه صـورت دسـتی قابـل      Inspector Viewهمچنین این کار در پنل . تغییر اندازه دهید
  .انجام است



  

  
  

  :خب حال بیایید مقداري از اشیاء صحنه را تغییر اندازه دهیم
 Inspector آن را از پنل Xمحور  ) Scale(  را انتخاب کرده و اندازه ي Planeشی  -

Viewقرار دهید10ابر  بر .  
بـا  . (  آن را به صورت ویژوال تغییر دهیدYمکعب را انتخاب کرده و اندازه ي محور      -

حال باید مکعب شما شبیه ).  و درگ کردن مربع سبز رنگ به سمت بالا           Rزدن کلید   
 .یک ستون شده باشد

 Hierarchyبراي این کار بر روي نام مکعب در .  تغییر نام دهیدPillarمکعب را به  -

View        کلیک راست کرده و گزینه ي Rename    را انتخاب کرده ونـام مـورد نظـر را 
 . براي نامگذاري اشیاء اولین حرف نام آنها حروف بزرگ باشداستبهتر. وارد کنید

  
  
   )Asset( استفاده از محتویات . 9

 غیره  بازي هاي کامپیوتري از مدلهاي سه بعدي، تکسچرها، فایل هاي صوتی، کدهاي بازي و             
 در درون خـود  Unity. نامیـده مـی شـوند    ) Asset( اینهـا محتویـات بـازي     . ساخته می شوند  



 Pro Standard و Standard Assetsمقدار زیادي محتوا به صورت پیش فرض با نام هـاي  

Assetsدارد .  
در .  به پروژه ي بازي خود اضـافه مـی کنـیم           Unity شخصیت از محتویات داخلی      کحال ما ی  

 وجـود دارد کـه در داخـل آن نیـز     Standard Assets پوشه اي بـا نـام   Project Viewپنل
  مجموعه اي از اشیاي بازي است کـه قـبلا          Prefabیک  .  موجود است  Prefabپوشه اي به نام     

 First Person Controller ) FPSشـما بایـد   . در داخل گروهی منطقی جمع آوري شده اند

Controller (  را در داخل پوشه يPrefabببینید .  
- Prefab   مربـوط بـه FPS Controller     را بـه داخـل نمـاي صـحنه  )Scene View ( 

ایـن  . تغییـر مـی کنـد    ) Game View( دقت کنید که چگونه نماي بازي . درگ کنید
 داراي دوربـین خـودش   FPS Controller مربـوط بـه   Prefabبه این دلیل است که 
مطمـئن  . ت و آن را غیر فعال مـی کنـد   مقدم اسMain Cameraاست که بر دوربین 

 نرفته باشد و مکـان آن را مقـداري   Plane داخل شی ه بFPS Controllerشوید که 
  . حرکت دهیدPlane به بالاي شی

چـون دیگـر نیـازي بـه آن      ). Deleteبـا کلیـک   (  را پاك کنیـد Main Cameraشی  -
 .واهید دیدنماي بازي همان چیزي است که در هنگام اجراي بازي خ. نداریم

 Unity در بـالاي ادیتـور    Playبراي این کـار بـر روي دکمـه ي           . بازي را شروع کنید    -
 تغییري نمی کنـد و شـما مـی         Unityدقت کنید که چیدمان محیط کاري       . کلیک کنید 

 ) Scene View( و نمـاي صـحنه    ) Game View( توانیـد بـازي را در نمـاي بـازي    
 و حرکت دادن ماوس در داخل محیط      W.S.A.Dببینید و در نماي بازي با کلید هاي         

 .بازي حرکت کنید

 ایـن کـار را مـی توانیـد انجـام        Playبا زدن دوباره ي دکمـه ي        . بازي را متوقف کنید    -
 .دهید

  
  

  اضافه کردن کامپوننت ها. 10
بـا  . داشته باشند که به آنها اضافه می شـود        ) یا رفتار (اشیاء بازي  می توانند تعدادي کامپوننت      

 Inspector بر روي هر شی می توانید کامپوننت هـاي اضـافه شـده بـه آن را در پنـل      کلیک

Viewمانند ( . ببینیدTransform-Box Collider و .(...  



 Inspector View کلیک کنیـد و کامپوننـت هـاي آن را در پنـل     Pillarبر روي شی  -
  .ضافه کنیمبیایید مکعب دیگري بسازیم و کامپوننت هاي بیشتري به آن ا. ببینید

 بـــه Hierarchy Viewنـــام آن را در . دمکعـــب دیگـــري را در صـــحنه بـــسازی  -
PhysicsCube  حال ما کامپوننت    .  تغییر دهیدRigidbody        را به این مکعـب اضـافه 

این کامپوننت به شی بازي اجازه مـی دهـد کـه ماننـد دنیـاي واقعـی داراي                   . می کنیم 
ین کامپوننت به آن اضافه شده اسـت    یعنی شی اي که ا    . خاصیت وزن و سنگینی باشد    

 دارد برخـورد   Collider کـه کامپوننـت      Planeمت پایین رها می شود و با شـی          سبه  
 .نکه با زمین برخورد کرده استآدرست مانند . می کند

از منـوي اصـلی گزینـه ي    .  انتخاب شـده اسـت  PhysicsCubeمطمئن شوید که شی     -
Component>Physics>Rigidbody ــد را انتخـــاب ــار کامپوننـــت  . کنیـ ایـــن کـ

Rigidbody  ــد ــه شــی انتخــاب شــده اضــافه مــی کن ــد کــه در پنــل  .  را ب دقــت کنی
Inspector View مربوط به این شی، کامپوننت Rigidbodyاضافه شده است . 

البته دقیقـا روي هـم قـرار    .  حرکت دهیدPillar بالاي شی هرا ب PhysicsCubeشی  -
خواهیـد دیـد کـه    .  کنیـد Playحال صحنه را   . یردرست مانند تصویر ز   . نگرفته باشند 

  برخورد می کند و سپس بـه سـمت  Pillar سقوط کرده و به شی   PhysicsCubeشی  
 . برخورد می کند و روي آن می افتدPlaneپایین سقوط می کند و به شی 

  

  
  

  



   )Duplicate( دونسخه کردن . 11
 با دو نـسخه    . می باشد  Unity هاي   دو نسخه کردن اشیاء بازي یکی از قدرتمند ترین ویژگی         

ایـن خیلـی راه   . کردن هر شی تمام خواص و رفتار هاي آن به نسخه ي جدید کپـی مـی شـود     
 بیـشتري را بـه   PhysicsCubeحـال مـا شـی     . سریعی براي ساختن صحنه هاي پیچیده است      

  .صحنه اضافه می کنیم
 مـی بینیـد کـه    حـال .  را بزنیـد Ctrl + D کلیک کرده و PhysicsCubeبر روي شی  -

ولـی آن را در  .  اضـافه مـی شـود   Hierarchy View اضـافی در  PhysicsCubeشی 
 اولیه در   PhysicsCubeچون درست در همان مکانی است که شی         . صحنه نمی بینید  

  .موجود استآن 
 به مقداري بالاتر حرکـت      W جدید را با استفاده از ابزار حرکت         PhysicsCubeشی   -

 .دهید

 . دیگر ساخته و آن را نیز بالا تر ببریدPhisicsCubeیک شی  -

 به سـمت پـایین     PhisicsCubeخواهید دید که هر سه شی       .  کنید Playحال بازي را     -
 .سقوط می کنند

  

  
  
  



  :پایان
حال شما بعـد از ایـن آمـوزش    . Unityاین آموزش مقدمه اي بود بر پایه هاي واسط کاربري     

  .العه کنید را مطUnityباید آموزش اسکریپت نویسی در 

  
  
  


